Ankündigung

Einklappen
Keine Ankündigung bisher.

Weiterleitung mit hatccess löst Error 500 aus

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Weiterleitung mit hatccess löst Error 500 aus

    Hallo,

    ich habe eine eigene Weiterleitungsdomain, aber wenn man diese aufruft, kommt Error 500 (natürlich mit einem gültigen Link). Die Weiterleitung ist, ist in meiner .htaccess Datei:

    Code:
    RewriteEngine On
    
    # Domain Wikipedia
    RewriteEngine on
    Redirect 301 /domain https://de.wikipedia.org/wiki/Domain_(Internet)
    
    # freenom
    RewriteEngine on
    Redirect 301 /freenom https://www.freenom.com
    
    # dot.tk
    RewriteEngine on
    Redirect 301 /dot http://www.dot.tk
    
    # web4free
    RewriteEngine on
    Redirect 301 /web4free https://www.web4free.eu/
    
    # strato
    RewriteEngine on
    Redirect 301 /strato https://www.strato.de/
    
    # wordpress.org
    RewriteEngine on
    Redirect 301 /wordpress https://wordpress.org/
    
    # de.wordpress.org
    RewriteEngine on
    Redirect 301 /dewordpress https://de.wordpress.org/
    
    # de.wordpress download
    RewriteEngine on
    Redirect 301 /dewordpressdownload https://de.wordpress.org/download/
    
    # elementor
    RewriteEngine on
    Redirect 301 /elementor https://elementor.com/
    
    # elementordownload
    RewriteEngine on
    Redirect 301 /elementordownload https://de.wordpress.org/plugins/elementor/ https://wpastra.com/
    
    # wpastra
    RewriteEngine on
    Redirect 301 /wpastra https://wpastra.com/
    
    # wpastradownload
    RewriteEngine on
    Redirect 301 /wpastradownload https://de.wordpress.org/themes/astra/
    
    # oceanwp
    RewriteEngine on
    Redirect 301 /oceanwp https://oceanwp.org/
    
    # oceanwpdownload
    RewriteEngine on
    Redirect 301 /oceanwpdownload https://de.wordpress.org/themes/oceanwp/
    Danke im Vorhinein.
    AGW von AGW International

  • #2
    Das ist eine merkwürdige htaccess Datei nimm mal den / am Ende des URLS raus und probier es es ohne
    https://arnego2.com <Webseiten, Umbau ab €80 und einiges mehr>

    VPS 8GB RAM 50 GB ROM < Server in der EU, 1rstes Jahr €38

    Kommentar


    • #3
      Zitat von arnego2 Beitrag anzeigen
      Das ist eine merkwürdige htaccess Datei nimm mal den / am Ende des URLS raus und probier es es ohne
      Habe ich gemacht. Meine Datei schaut jetzt so aus:

      Code:
      RewriteEngine On
      
      # Domain Wikipedia
      RewriteEngine on
      Redirect 301 /domain https://de.wikipedia.org/wiki/Domain_(Internet)
      
      # freenom
      RewriteEngine on
      Redirect 301 /freenom https://www.freenom.com
      
      # dot.tk
      RewriteEngine on
      Redirect 301 /dot http://www.dot.tk
      
      # web4free
      RewriteEngine on
      Redirect 301 /web4free https://www.web4free.eu
      
      # strato
      RewriteEngine on
      Redirect 301 /strato https://www.strato.de
      
      # wordpress.org
      RewriteEngine on
      Redirect 301 /wordpress https://wordpress.org
      
      # de.wordpress.org
      RewriteEngine on
      Redirect 301 /dewordpress https://de.wordpress.org
      
      # de.wordpress download
      RewriteEngine on
      Redirect 301 /dewordpressdownload https://de.wordpress.org/download
      
      # elementor
      RewriteEngine on
      Redirect 301 /elementor https://elementor.com
      
      # elementordownload
      RewriteEngine on
      Redirect 301 /elementordownload https://de.wordpress.org/plugins/elementor/ https://wpastra.com
      
      # wpastra
      RewriteEngine on
      Redirect 301 /wpastra https://wpastra.com
      
      # wpastradownload
      RewriteEngine on
      Redirect 301 /wpastradownload https://de.wordpress.org/themes/astra
      
      # oceanwp
      RewriteEngine on
      Redirect 301 /oceanwp https://oceanwp.org
      
      # oceanwpdownload
      RewriteEngine on
      Redirect 301 /oceanwpdownload https://de.wordpress.org/themes/oceanwp
      Error 500 bleibt weiterhin. Sind Links die mein Freund für seine YouTube-Videos verwendet, da bei Wikipedia hinten das ")" nicht als Link von YouTube erkannt wird und damit die ganze Video-Beschreibung besser aussieht wollte er alle Link mit meiner Domain haben.
      AGW von AGW International

      Kommentar


      • #4
        Warum auch immer man nicht einfach in html den richtigen Link setzt.

        Diese Zeile hat wohl einen Parameter zuviel:

        Code:
        Redirect 301 /elementordownload https://de.wordpress.org/plugins/elementor/ https://wpastra.com

        Kommentar


        • #5
          Zitat von Testie Beitrag anzeigen
          Warum auch immer man nicht einfach in html den richtigen Link setzt.

          Diese Zeile hat wohl einen Parameter zuviel:

          Code:
          Redirect 301 /elementordownload https://de.wordpress.org/plugins/elementor/ https://wpastra.com
          DANKE!!! Das war das Problem. Jetzt funktioniert es wieder.
          AGW von AGW International

          Kommentar

          homepage-forum.de - Hilfe für Webmaster! Statistiken

          Einklappen

          Themen: 56.776   Beiträge: 429.827   Mitglieder: 28.527   Aktive Mitglieder: 53
          Willkommen an unser neuestes Mitglied, McFrey72.

          Online-Benutzer

          Einklappen

          264 Benutzer sind jetzt online. Registrierte Benutzer: 1, Gäste: 263.

          Mit 3.502 Benutzern waren am 23.01.2020 um 18:20 die meisten Benutzer gleichzeitig online.

          Die neuesten Themen

          Einklappen

          • ST747
            Antwort auf Bing BOT webmaster
            o.k.,jetzt ist mir das klar, alles o.k., hatte den bingbot falsch verstanden.

            Ich dachte, da muss ich meine ip-adresse von meinem server eingeben.
            aber damit kann ich prüfen, ob mit der richtigen ip-adresse von bingbot auf meine
            site zugegriffen wird. muss man also nicht machen,...
            Gestern, 19:29
          • daniel5959
            Antwort auf SSL-Zertifikat bzw. DNS Eintrag bei evanzo???
            Hallo,

            die .htaccess wird gebraucht, um von den alten HTTP-Adressen zu den sicheren HTTPS-Adressen weiterzuleisten.

            Seiten, die schon länger im Internet sind, sind auf anderen Webseiten noch mit den alten HTTP-Adressen verlinkt und hierfür braucht es die Weiterleitungen per...
            Gestern, 19:17
          • Mys87
            Antwort auf SSL-Zertifikat bzw. DNS Eintrag bei evanzo???
            Ja, ich habe es mittlerweile mit Hilfe des Supports (man muss nicht anrufen, man kann auch ein Ticket öffnen und bekommt ganz bequem und schnell eine Antwort per Mail) hinbekommen. Es ist tatsächlich ganz einfach, man muss halt nur wissen wie ;-)

            1. Im Plesk gibt es den Menüpunkt Let's...
            Gestern, 18:12
          • Sempervivum
            Antwort auf Welchen Editor kommt bei euch zum Einsatz
            Danke, x-Debug ist konfiguriert, am Anfang funktioniert ja auch immer alles. Ich benutze nicht Apache sondern aus historischen Gründen IIS Express. Ob es wohl daran liegt?
            Gestern, 17:49
          • Megabyte
            Antwort auf Welchen Editor kommt bei euch zum Einsatz
            Hallo Sempervivum

            Ich nutze auch das AddOn von Felix Becker. Das Aufhängen hat (denke ich) Konfig-Ursachen. Die ist kniffig und nachdem ich heute das nochmals startete - siehe da: geht auch nicht mehr *muahahahaha*. Werde es nochmals konfigurieren müssen.

            Wichtig: 'PHP Debug'...
            Gestern, 17:42

          Die neuesten Beiträge

          Einklappen

          • ST747
            Bing BOT webmaster
            Hallo, ich habe für 2 webseiten das webspace-packet einfach getauscht,
            da das eine einen größeren leistungsumfang hat.
            jetzt funktioniert aber der bing-bot nicht mehr.
            ggf. habe ich da auch eine datei vertauscht.
            bei provider ist natürlich auch die ip-adresse für der server...
            17.01.2021, 15:43
          • ST747
            Antwort auf Bing BOT webmaster
            o.k.,jetzt ist mir das klar, alles o.k., hatte den bingbot falsch verstanden.

            Ich dachte, da muss ich meine ip-adresse von meinem server eingeben.
            aber damit kann ich prüfen, ob mit der richtigen ip-adresse von bingbot auf meine
            site zugegriffen wird. muss man also nicht machen,...
            Gestern, 19:29
          • Mys87
            SSL-Zertifikat bzw. DNS Eintrag bei evanzo???
            Hallo zusammen,

            da ein SSL-Zertifikat mittlerweile wohl Standard ist würde ich nun auch gerne eins einsetzen. Bin bei evanzo und da habe ich auch schon die Möglichkeit eines kostenloses Zertifikates über let's encrypt gefunden. Nun soll man ein DNS Eintrag erstellen und da komme ich...
            15.01.2021, 18:13
          • daniel5959
            Antwort auf SSL-Zertifikat bzw. DNS Eintrag bei evanzo???
            Hallo,

            die .htaccess wird gebraucht, um von den alten HTTP-Adressen zu den sicheren HTTPS-Adressen weiterzuleisten.

            Seiten, die schon länger im Internet sind, sind auf anderen Webseiten noch mit den alten HTTP-Adressen verlinkt und hierfür braucht es die Weiterleitungen per...
            Gestern, 19:17
          • Mys87
            Antwort auf SSL-Zertifikat bzw. DNS Eintrag bei evanzo???
            Ja, ich habe es mittlerweile mit Hilfe des Supports (man muss nicht anrufen, man kann auch ein Ticket öffnen und bekommt ganz bequem und schnell eine Antwort per Mail) hinbekommen. Es ist tatsächlich ganz einfach, man muss halt nur wissen wie ;-)

            1. Im Plesk gibt es den Menüpunkt Let's...
            Gestern, 18:12
          • Sempervivum
            Antwort auf Welchen Editor kommt bei euch zum Einsatz
            Danke, x-Debug ist konfiguriert, am Anfang funktioniert ja auch immer alles. Ich benutze nicht Apache sondern aus historischen Gründen IIS Express. Ob es wohl daran liegt?
            Gestern, 17:49
          • Megabyte
            Antwort auf Welchen Editor kommt bei euch zum Einsatz
            Hallo Sempervivum

            Ich nutze auch das AddOn von Felix Becker. Das Aufhängen hat (denke ich) Konfig-Ursachen. Die ist kniffig und nachdem ich heute das nochmals startete - siehe da: geht auch nicht mehr *muahahahaha*. Werde es nochmals konfigurieren müssen.

            Wichtig: 'PHP Debug'...
            Gestern, 17:42
          • Sempervivum
            Antwort auf Welchen Editor kommt bei euch zum Einsatz
            Megabyte Ich benutze ebenfalls VS-Code und bin voll zufrieden. Was bei mir nicht richtig funktioniert ist der Debugger für PHP: Er hängt sich dauernd auf, so dass nichts mehr geht und es ist mir unklar, ob es an der Erweiterung liegt oder an Bedienungsfehlern meinerseits. Wie sind deine Erfahrungen...
            Gestern, 06:14
          • Megabyte
            Antwort auf Wie viele Websietenbesucher habt ihr?
            Wie versprochen: Wenn ich die crawler aussortiert habe - was bleibt übrig:

            Habe nun im Monat Dezember mein Besucherskript dahingehend erweitert dass er crawler und bots ausklammert und mittels
            'session' abfrägt ob sich "Wiederholungstäter" auf meiner Page finden.
            ...
            23.01.2021, 23:18
          • Megabyte
            Antwort auf Welchen Editor kommt bei euch zum Einsatz
            Mein Fazit:

            Nachdem ich fast alle Editoren nun durchhabe bin ich bei vsCode geblieben. Warum?

            Sehr gutes Highlighning über sehr viele Sprachen, komplett individuell konfigurierbar
            (und zwar WIRKLICH komplett !!!), fertig integrierte EMMETs und SNIPPETs - auch frei...
            23.01.2021, 22:55
          Lädt...
          X