Ankündigung

Einklappen
Keine Ankündigung bisher.

Link bei negativem margin nicht erreichbar

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Link bei negativem margin nicht erreichbar

    Hallo,

    zur Zeit raffe ich wieder gar nichts.

    Auf meiner Seite habe ich oben rechts eine "Top-Navigation", die ich mit einem margin:-2.2em; über das Headerbild lege.
    Bisher hatte ich dort nur einfache Textlinks und es funktionierte. Jetzt wollte ich das auf eine ul umstellen und es geht nicht mehr. Die Links sind nicht mehr anklickbar.
    Ich habe schon alles Mögliche Probiert (ul in einen zusätzlichen Container, display:inline durch float ersetzt, z-index ... usw.) bin aber zu keinem Ergebnis gekommen.

    Hat jemand einen Vorschlag für mich?
    http://www.peterressel.de/Test/


    Peter
    Zuletzt geändert von Peter0308; 23.09.2007, 18:25. Grund: URL falsch geschrieben
    Mein kostenloser Image-Hoster, mit freier Galerie (GNU GPL) pere-image
    Mein neuer Versuch .... und
    hiermit verdiene ich mein Geld.

  • #2
    AW: Link bei negativem margin nicht erreichbar

    Der richtige Link ist http://www.peterressel.de/Test/

    Bei mir geht es im IE, nur im FF nicht.

    Kommentar


    • #3
      AW: Link bei negativem margin nicht erreichbar

      Hi,

      du warst schneller wie ich mit meiner Linkkorrektur.

      Im IE funktioniert es einwandfrei, aber FF und Opera weigern sich ... also hab ich wohl irgendwo was falsch gemacht.
      Komischerweise funktioniert es mit reinen Textlinks ... siehe die noch "offizielle" Seite: http://www.peterressel.de/

      Peter
      Mein kostenloser Image-Hoster, mit freier Galerie (GNU GPL) pere-image
      Mein neuer Versuch .... und
      hiermit verdiene ich mein Geld.

      Kommentar


      • #4
        AW: Link bei negativem margin nicht erreichbar

        Hallo Peter,

        hast du schon umgestellt? Denn bei mir geht im Opera die Navigation auch nicht auf der noch offiziellen Seite

        Gruß
        Catja

        Kommentar


        • #5
          AW: Link bei negativem margin nicht erreichbar

          Hi Catja,

          du hast recht.
          Das war mir noch gar nicht aufgefallen.

          Vielleicht habe ich am nächsten Wochenende wieder etwas mehr Ruhe, dann werde ich mich darum kümmern.

          Peter
          Mein kostenloser Image-Hoster, mit freier Galerie (GNU GPL) pere-image
          Mein neuer Versuch .... und
          hiermit verdiene ich mein Geld.

          Kommentar


          • #6
            AW: Link bei negativem margin nicht erreichbar

            Hi,
            Zitat von Peter0308 Beitrag anzeigen
            Komischerweise funktioniert es mit reinen Textlinks ... siehe die noch "offizielle" Seite
            Du solltest dir die Webdeveloper Toolbar für den Firefox installieren. Damit kommst Du schnell auf die Ursache solcher Probleme. Mal eben die IDs, Classes und Blockelemente markiert und dann die "typgrafische" Ansicht aktiviert:
            Angehängte Dateien
            Ingo Webdesign

            Kommentar


            • #7
              AW: Link bei negativem margin nicht erreichbar

              Hi Ingo,

              die Webdeveloper Toolbar habe ich schon seit einiger Zeit installiert, aber noch nicht alle Funktionen davon ausprobiert. Danke für den Tipp.

              Ich habe das Problem jetzt gelöst (durch Einfügen von "position:relative; bei den <li>). Allerdings fehlen mir dabei einige Hintergrundinfo's.

              Ich weiß einfach nicht, warum die <a href....>-Tags nicht aktiv waren. Während die eigentliche Schrift des Links zu sehen war. Und warum das nur dann nicht geht, wenn ich die Liste über dem Bild positioniere.
              Ich vermute einfach mal, dass das irgendwas damit zu tun hat, dass die <li>-Tags Inlineelemente sind und durch die Anweisung position:relativ zu Blockelementen gemacht werden .... aber einleuchten tut mir das noch nicht.

              Gibt es da eine Stelle (z.B. bei selfhtml) wo ich genaue Informationen dazu bekomme?

              Peter
              Mein kostenloser Image-Hoster, mit freier Galerie (GNU GPL) pere-image
              Mein neuer Versuch .... und
              hiermit verdiene ich mein Geld.

              Kommentar


              • #8
                AW: Link bei negativem margin nicht erreichbar

                Hi,
                Zitat von Peter0308 Beitrag anzeigen
                Ich weiß einfach nicht, warum die <a href....>-Tags nicht aktiv waren. Während die eigentliche Schrift des Links zu sehen war. Und warum das nur dann nicht geht, wenn ich die Liste über dem Bild positioniere.
                Nein, das hast Du eben nicht. Die Links lagen - wie dir die typografische Ansicht zeigt - unter dem Bild. Sichtbar waren sie nur, weil das Bild an dieser Stelle transparent ist. Anklicken konntest Du daher aber nur das Bild.

                Gruß
                Ingo
                Ingo Webdesign

                Kommentar


                • #9
                  AW: Link bei negativem margin nicht erreichbar

                  Hi Ingo,

                  danke für deine Erklärung.

                  Was mir jetzt noch unklar ist, warum die Links "unter" dem Bild waren obwohl ich den z-index höher hatte als den des Bildes.
                  Und warum holt position:relativ die Links in den Vordergrund?

                  Sorry, wenn ich diese Fragen stelle, aber ich interessiere mich halt auch für die Background-Infos und zumindest bei selfhtml finde ich keine Erklärung.

                  Peter
                  Mein kostenloser Image-Hoster, mit freier Galerie (GNU GPL) pere-image
                  Mein neuer Versuch .... und
                  hiermit verdiene ich mein Geld.

                  Kommentar


                  • #10
                    AW: Link bei negativem margin nicht erreichbar

                    Hi,
                    Zitat von Peter0308 Beitrag anzeigen
                    obwohl ich den z-index höher hatte als den des Bildes.
                    Und warum holt position:relativ die Links in den Vordergrund?
                    weil z-index nur für (anders als static) positionierte Elemente gilt.

                    Gruß
                    Ingo
                    Ingo Webdesign

                    Kommentar


                    • #11
                      AW: Link bei negativem margin nicht erreichbar

                      Hi,

                      vielen Dank Ingo.

                      Das hat mir doch um einiges weitergeholfen. Ich muss zugeben, dass ich "static" noch gar nicht kannte (und immer noch nicht kenne), was sich aber innerhalb der nächsten halben Stunde ändern wird.

                      Nochmals Danke.

                      Peter
                      Mein kostenloser Image-Hoster, mit freier Galerie (GNU GPL) pere-image
                      Mein neuer Versuch .... und
                      hiermit verdiene ich mein Geld.

                      Kommentar

                      homepage-forum.de - Hilfe für Webmaster! Statistiken

                      Einklappen

                      Themen: 56.776   Beiträge: 429.822   Mitglieder: 28.527   Aktive Mitglieder: 53
                      Willkommen an unser neuestes Mitglied, McFrey72.

                      Online-Benutzer

                      Einklappen

                      282 Benutzer sind jetzt online. Registrierte Benutzer: 3, Gäste: 279.

                      Mit 3.502 Benutzern waren am 23.01.2020 um 18:20 die meisten Benutzer gleichzeitig online.

                      Die neuesten Themen

                      Einklappen

                      • Sempervivum
                        Antwort auf Welchen Editor kommt bei euch zum Einsatz
                        Megabyte Ich benutze ebenfalls VS-Code und bin voll zufrieden. Was bei mir nicht richtig funktioniert ist der Debugger für PHP: Er hängt sich dauernd auf, so dass nichts mehr geht und es ist mir unklar, ob es an der Erweiterung liegt oder an Bedienungsfehlern meinerseits. Wie sind deine Erfahrungen...
                        Heute, 06:14
                      • Megabyte
                        Antwort auf Wie viele Websietenbesucher habt ihr?
                        Wie versprochen: Wenn ich die crawler aussortiert habe - was bleibt übrig:

                        Habe nun im Monat Dezember mein Besucherskript dahingehend erweitert dass er crawler und bots ausklammert und mittels
                        'session' abfrägt ob sich "Wiederholungstäter" auf meiner Page finden.
                        ...
                        Gestern, 23:18
                      • Megabyte
                        Antwort auf Welchen Editor kommt bei euch zum Einsatz
                        Mein Fazit:

                        Nachdem ich fast alle Editoren nun durchhabe bin ich bei vsCode geblieben. Warum?

                        Sehr gutes Highlighning über sehr viele Sprachen, komplett individuell konfigurierbar
                        (und zwar WIRKLICH komplett !!!), fertig integrierte EMMETs und SNIPPETs - auch frei...
                        Gestern, 22:55
                      • daniel5959
                        Antwort auf SSL-Zertifikat bzw. DNS Eintrag bei evanzo???
                        Hallo,

                        habe bei Evanzo diese Infos bei den Webhosting-Paketen und beim Linux vServer gefunden, siehe



                        Falls diese Infos von Evanzo und 1Blu stimmen, dann ist es so einfach wie bei Strato, ein Mausklick und das SSL-Zertifikat müsste eingerichtet sein - evtl. bis...
                        Gestern, 22:38
                      • McFrey72
                        Antwort auf SSL-Zertifikat bzw. DNS Eintrag bei evanzo???
                        Hallo,
                        stehe vor genau dem selben Dilemma: kein Plan!
                        Bist du mit deinem Ticket schon weiter gekommen? Ist ja noch relativ "warm", das Thema.
                        Der telefonischer Support von Evanzo ist leider genau dann erreichbar wenn ich selber arbeite. :-/
                        Wäre toll wenn du das erklärst...
                        Gestern, 21:31

                      Die neuesten Beiträge

                      Einklappen

                      • Sempervivum
                        Antwort auf Welchen Editor kommt bei euch zum Einsatz
                        Megabyte Ich benutze ebenfalls VS-Code und bin voll zufrieden. Was bei mir nicht richtig funktioniert ist der Debugger für PHP: Er hängt sich dauernd auf, so dass nichts mehr geht und es ist mir unklar, ob es an der Erweiterung liegt oder an Bedienungsfehlern meinerseits. Wie sind deine Erfahrungen...
                        Heute, 06:14
                      • Megabyte
                        Antwort auf Wie viele Websietenbesucher habt ihr?
                        Wie versprochen: Wenn ich die crawler aussortiert habe - was bleibt übrig:

                        Habe nun im Monat Dezember mein Besucherskript dahingehend erweitert dass er crawler und bots ausklammert und mittels
                        'session' abfrägt ob sich "Wiederholungstäter" auf meiner Page finden.
                        ...
                        Gestern, 23:18
                      • Megabyte
                        Antwort auf Welchen Editor kommt bei euch zum Einsatz
                        Mein Fazit:

                        Nachdem ich fast alle Editoren nun durchhabe bin ich bei vsCode geblieben. Warum?

                        Sehr gutes Highlighning über sehr viele Sprachen, komplett individuell konfigurierbar
                        (und zwar WIRKLICH komplett !!!), fertig integrierte EMMETs und SNIPPETs - auch frei...
                        Gestern, 22:55
                      • Mys87
                        SSL-Zertifikat bzw. DNS Eintrag bei evanzo???
                        Hallo zusammen,

                        da ein SSL-Zertifikat mittlerweile wohl Standard ist würde ich nun auch gerne eins einsetzen. Bin bei evanzo und da habe ich auch schon die Möglichkeit eines kostenloses Zertifikates über let's encrypt gefunden. Nun soll man ein DNS Eintrag erstellen und da komme ich...
                        15.01.2021, 18:13
                      • daniel5959
                        Antwort auf SSL-Zertifikat bzw. DNS Eintrag bei evanzo???
                        Hallo,

                        habe bei Evanzo diese Infos bei den Webhosting-Paketen und beim Linux vServer gefunden, siehe



                        Falls diese Infos von Evanzo und 1Blu stimmen, dann ist es so einfach wie bei Strato, ein Mausklick und das SSL-Zertifikat müsste eingerichtet sein - evtl. bis...
                        Gestern, 22:38
                      • McFrey72
                        Antwort auf SSL-Zertifikat bzw. DNS Eintrag bei evanzo???
                        Hallo,
                        stehe vor genau dem selben Dilemma: kein Plan!
                        Bist du mit deinem Ticket schon weiter gekommen? Ist ja noch relativ "warm", das Thema.
                        Der telefonischer Support von Evanzo ist leider genau dann erreichbar wenn ich selber arbeite. :-/
                        Wäre toll wenn du das erklärst...
                        Gestern, 21:31
                      • Joschiiie96
                        Jimdo - Problem mit Sprungmarke bei Onepager
                        Servus Community,

                        für das Geschäft eines Freundes habe ich einen kleinen Onepager mithilfe von Jimdo erstellt. Nachdem der Entwurf nun fast fertig ist, haben wir das Pro-Paket von Jimdo gekauft, da es erst damit möglich ist, die Menüpunkte mit individuellen Links zu verknüpfen (und...
                        21.01.2021, 21:24
                      • arnego2
                        Antwort auf Jimdo - Problem mit Sprungmarke bei Onepager
                        auf Jimdo sein Geschäft aufbauen, das ist sicher ein Weg Erfahrungen zu sammeln.

                        für €20 pro Monat, 240 pro Jahr bekommt man 2 Jahre VPS, mit Einrichtung plus Webseite, emails und allen drum herum. Eventuell ist da sogar ein Sectico SSL.
                        Für die Hälfte, also €120 bekommt man...
                        21.01.2021, 22:26
                      • daniel5959
                        Antwort auf Jimdo - Problem mit Sprungmarke bei Onepager
                        Nachtrag:

                        Wenn nur innerhalb der gleichen Seite verlinkt wird, dann genügt als Adresse des Links der betreffende Anker, z.B.

                        #sortiment

                        Hier habe ich eine Anleitung dazu von Jimdo gefunden, siehe

                        >> https://help.jimdo.com/hc/de/articles/1150...
                        21.01.2021, 22:18
                      • daniel5959
                        Antwort auf Jimdo - Problem mit Sprungmarke bei Onepager
                        Hallo,

                        im Quelltext taucht bei den Menülinks ein ...

                        HTML-Code:
                        target="_blank"
                        ... auf, also eine Anweisung an den Browser einen neuen Tab aufzumachen.

                        Ich arbeite jetzt nicht mit dem Jimdo-Baukasten.

                        Irgendwo beim Linksetzen gibt es wohl...
                        21.01.2021, 22:08
                      Lädt...
                      X