Ankündigung

Einklappen
Keine Ankündigung bisher.

Validations-Fehler bei <table>

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Validations-Fehler bei <table>

    Hallo zusammen,

    bei nachfolgender Codierung
    HTML-Code:
    <table>
      <thead>
        <tr>
          <th class="t140">Datum (von-bis)</th>
          <th class="t140">Uhrzeit (von-bis)</th>
          <th class="t460">Beschreibung</th>
        </tr>
      </thead>
    </table>             <-- Zeile 118
    erhalte ich folgende Fehler-Meldung :
    Line 118, Column 7: end tag for "table" which is not finished .
    </table>
    Most likely, you nested tags and closed them in the wrong order.......
    Die Reihenfolge (open/close) stimmt.

    Kann mir jemand verraten, warum der Validator hier mosert ?

    Gruß, Mike
    Zuletzt geändert von sheeba1507; 12.10.2007, 12:41.
    sigpic
    Mike's EEP-Welt CSC Oldenburg
    Link-Sammlung Smily-Sammlung

  • #2
    AW: Validations-Fehler bei &lt;table&gt;

    Welche Zeile ist denn Zeile 118?
    There are 10 kind of people: those who understand binary and those who don't.

    Kommentar


    • #3
      AW: Validations-Fehler bei &lt;table&gt;

      Hi,
      Zitat von sheeba1507 Beitrag anzeigen
      Kann mir jemand verraten, warum der Validator hier mosert ?
      Weil die Tabelle unvollständig ist.

      <!ELEMENT table - - (caption?, (col*|colgroup*), thead?, tfoot?, tbody+)>

      besagt, dass ein oder mehrere tbody Plicht sind, wobei auf ein einzelnes tbody verzichtet werden kann - nur müssen dann die tr mit Inhalt natürlich vorhanden sein.
      Das ist das gleiche, als wenn Du eine ul ohne li-Elemente erstellst: Unsinn.

      Gruß
      Ingo
      Ingo Webdesign

      Kommentar


      • #4
        AW: Validations-Fehler bei &lt;table&gt;

        Sorry, habe vergessen, es einzutragen.
        Wurde soeben nachgeholt.

        @Ingo
        Soll das heißen, ich müsste irgendwo noch ein "tbody"
        einfügen ?
        Wenn ja, wo ? (Habe ich noch nie angewendet)

        Gruß, Mike


        Edit (autom. Beitragszusammenführung):

        Hi zusammen,

        das Problem hat sich erledigt.

        Ich habe die Codierung geändert auf
        HTML-Code:
        <table>
          <tr>
            <td class="t140"><strong>Datum (von-bis)</strong></td>
            <td class="t140"><strong>Uhrzeit (von-bis)</strong></td>
            <td class="t460"><strong>Beschreibung</strong></td>
          </tr>
        </table>
        Somit ist auch diese Seite valide.

        Gruß, Mike
        Zuletzt geändert von sheeba1507; 13.10.2007, 10:39. Grund: Antwort auf eigenen Beitrag innerhalb von 24 Stunden!
        sigpic
        Mike's EEP-Welt CSC Oldenburg
        Link-Sammlung Smily-Sammlung

        Kommentar


        • #5
          AW: Validations-Fehler bei &lt;table&gt;

          aber nicht css valide
          Meine neue private Homepage ist fertig. Es wird um Meinungen, Anregungen, Kritik und Gästebucheinträge gebeten: http://markus.ug-team.de

          Kommentar


          • #6
            AW: Validations-Fehler bei &lt;table&gt;

            Daran arbeite ich noch.
            Nur Geduld.

            Gruß, Mike
            sigpic
            Mike's EEP-Welt CSC Oldenburg
            Link-Sammlung Smily-Sammlung

            Kommentar


            • #7
              AW: Validations-Fehler bei &lt;table&gt;

              Hallo,

              "thead" ist für die Bezeichnung der Felder. Also z.B. Name, Beschreibung, Preis.
              "tbody" hingegen ist dazu gemacht, den Inhalt darzustellen. z.B. Computer, Intel Core 2 Duo, 1000 Sfr.

              Ich denke dass meinte Ingo.

              MFG
              [ASTERIX]

              Kommentar

              homepage-forum.de - Hilfe für Webmaster! Statistiken

              Einklappen

              Themen: 56.775   Beiträge: 429.816   Mitglieder: 28.526   Aktive Mitglieder: 54
              Willkommen an unser neuestes Mitglied, aschief.

              Online-Benutzer

              Einklappen

              161 Benutzer sind jetzt online. Registrierte Benutzer: 1, Gäste: 160.

              Mit 3.502 Benutzern waren am 23.01.2020 um 18:20 die meisten Benutzer gleichzeitig online.

              Die neuesten Themen

              Einklappen

              Die neuesten Beiträge

              Einklappen

              • Joschiiie96
                Jimdo - Problem mit Sprungmarke bei Onepager
                Servus Community,

                für das Geschäft eines Freundes habe ich einen kleinen Onepager mithilfe von Jimdo erstellt. Nachdem der Entwurf nun fast fertig ist, haben wir das Pro-Paket von Jimdo gekauft, da es erst damit möglich ist, die Menüpunkte mit individuellen Links zu verknüpfen (und...
                Gestern, 21:24
              • arnego2
                Antwort auf Jimdo - Problem mit Sprungmarke bei Onepager
                auf Jimdo sein Geschäft aufbauen, das ist sicher ein Weg Erfahrungen zu sammeln.

                für €20 pro Monat, 240 pro Jahr bekommt man 2 Jahre VPS, mit Einrichtung plus Webseite, emails und allen drum herum. Eventuell ist da sogar ein Sectico SSL.
                Für die Hälfte, also €120 bekommt man...
                Gestern, 22:26
              • daniel5959
                Antwort auf Jimdo - Problem mit Sprungmarke bei Onepager
                Nachtrag:

                Wenn nur innerhalb der gleichen Seite verlinkt wird, dann genügt als Adresse des Links der betreffende Anker, z.B.

                #sortiment

                Hier habe ich eine Anleitung dazu von Jimdo gefunden, siehe

                >> https://help.jimdo.com/hc/de/articles/1150...
                Gestern, 22:18
              • daniel5959
                Antwort auf Jimdo - Problem mit Sprungmarke bei Onepager
                Hallo,

                im Quelltext taucht bei den Menülinks ein ...

                HTML-Code:
                target="_blank"
                ... auf, also eine Anweisung an den Browser einen neuen Tab aufzumachen.

                Ich arbeite jetzt nicht mit dem Jimdo-Baukasten.

                Irgendwo beim Linksetzen gibt es wohl...
                Gestern, 22:08
              • Arfa
                Videoupload per Link
                Hallo Leute,

                ich bin leider unsicher, in welchem Unterforum ich mit diesem Anliegen am besten aufgehoben bin, aber es geht um Folgendes:

                Für ein Projekt meiner Gemeinde, welches im Sommer 2021 stattfinden wird, sollen uns Anwohner gefilmte Handyvideos der schönsten Plätze...
                Gestern, 12:09
              • arnego2
                Antwort auf Videoupload per Link
                Egal was tu tust, uploadlink mit 3 Schritten, >> https://wetransfer.com/ oder ApK runterladen anmelden und wie man teilt sind ebenfalls 3 Schritte. Um Lehren kommst du nicht vorbei. Es soll ja Leute geben die gerne Lernen.;(...
                Gestern, 16:45
              • Arfa
                Antwort auf Videoupload per Link
                Hallo daniel5959,

                die Pro Version dieser Seite scheint zumindest auf den ersten Blick exakt das zu sein, was ich suche.

                Vielen, vielen Dank!

                Edit:



                Das ist richtig, aber es handelt sich ja nicht um eine Gruppe von Menschen, denen ich...
                Gestern, 15:54
              • arnego2
                Antwort auf Videoupload per Link
                ab 60 gehört man ins Altersheim? Alter ist nur eine Nummer. Wenn du es so einfach machen willst wie möglich zeige ihnen wie man einem Video teilt (shared) Das geht über Telegram, Signal auch ohne Verluste.
                Das schicken sie zu dir und du gibst es weiter zur Schneideabteilung.

                meine...
                Gestern, 15:23
              • daniel5959
                Antwort auf Videoupload per Link
                Hallo,

                ein sehr einfach zu nutzender (wenn man will, auch kostenloser) Anbieter ist z.B.

                >> https://wetransfer.com/

                Einfache Nutzung: Datei oder Ordner auswählen, Empfänger-Mail und eigene Mailadresse angeben - dann auf Senden klicken.

                Der...
                Gestern, 14:53
              • ST747
                Bing BOT webmaster
                Hallo, ich habe für 2 webseiten das webspace-packet einfach getauscht,
                da das eine einen größeren leistungsumfang hat.
                jetzt funktioniert aber der bing-bot nicht mehr.
                ggf. habe ich da auch eine datei vertauscht.
                bei provider ist natürlich auch die ip-adresse für der server...
                17.01.2021, 15:43
              Lädt...
              X