Ankündigung

Einklappen
Keine Ankündigung bisher.

Übergabe von Variablen

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Übergabe von Variablen

    Hallo... Ich hab mal ne Frage...

    ALso wenn ich in einer php-Datei ein Formular habe das so ausieht:
    <form action="form2.php" method="post">
    <input type="text" size="17" name="Inhalt">
    <br><br>
    <center>
    <input type="submit" value="OK">
    </center>
    </form>
    Und dann die Datei form2.php anlege und da reinschreibe:
    <? echo $Inhalt; ?>
    , sollte er ja eigentlich in die neue Datei reinschreiben, was der User in das Feld mit dem Namen "Inhalt" geschrieben hat.

    Das funzt bei mir net. Die Datei bleibt einfach leer(Im Browser)
    Warum denn?? Was hab ich falsch gemacht?

  • #2
    auf den erstenb blick erkenn ich keinen fehler...

    aber achte mal auf die gross un klein schreinug (hier ist kein fehler aber im script ja evtl. schom...)

    und dann musst dzu noch die dateien erst uploaden oder mit apache öffnen, sonst bleibt die datei auch leer.
    www.nice-esp.de.vu - meldet bitte mal im board an: wir versuchen eine nette HL:CS / Games community aufzubauen(nich so wie cstrike.de oder mymtw.de)

    Kommentar


    • #3
      Naja klar... Also ích hab alles Versucht, den Variablen auch kürzere namen gegeben, dsodass ich keinen Fehler machen konnt... Aber es hat nihct geklappt.

      Aso... Ich hab gelesen, dass MySQL bei Win ME nicht geht... Stimmt das?

      Kommentar


      • #4
        ka was mit me ist... abetr das da oben hat nix mit mysql zu tun!
        www.nice-esp.de.vu - meldet bitte mal im board an: wir versuchen eine nette HL:CS / Games community aufzubauen(nich so wie cstrike.de oder mymtw.de)

        Kommentar


        • #5
          Ist schon klar, das war auch nur eine Nebenfrage..

          SPages... Weisst du vielleicht was ich falsch mache?

          Kommentar


          • #6
            Hi,
            Habe es mal schnell bei mir getestet (Win98) und es geht.

            hm ... irgendwas war mit Win ME - ich glaube PHP oder Apache lief da nicht. Hast du schon mal

            <? phpinfo() ?>

            getestet??


            MfG SPages
            Lernen Sie jetzt PHP
            http://www.php-is-easy.de/obook

            Kommentar


            • #7
              Hi,
              Welche Apache Version hast du 1.3.x oder 2.0.x?


              MfG SPages
              Lernen Sie jetzt PHP
              http://www.php-is-easy.de/obook

              Kommentar


              • #8
                Also habe erst gerade angefangen mit PHP, also kann es auch Quatsch sein was ich schreibe!

                du schreibst ja: <? echo $Inhalt; ?>

                Aber bei dem Formular hat es kein $inhalt, wie soll der dann wissen was er mache muss?
                Ich bin Schweizer und das ist auch gut so!

                Kommentar


                • #9
                  Hi,
                  Doch ...

                  wenn du ein Forumular machtst und bei name="Inhalt" schreibst und das an ein PHP-Script sendest wird daraus die Variable $Inhalt.

                  MfG SPages
                  Lernen Sie jetzt PHP
                  http://www.php-is-easy.de/obook

                  Kommentar


                  • #10
                    Danke, jetzt habe ich was dazu gelernt!
                    Ich bin Schweizer und das ist auch gut so!

                    Kommentar


                    • #11
                      ja :!: , ich denke mal es liegt an Apache oder PHP das die alle nicht mit WinME und WinXP laufen, ich habe jetzt schon 3 Workshops durchgemacht und PHP Trial Installiert (PHPTrial ist ein Programm welches Apache, PHP und MySQL auf der festplatte speichert und einrichtet, also das es 100% lauffähig sein müßte) hier der Link http://sourceforge.net/projects/phptriad´

                      Also ich denke es liegt wirklich an WinME und WinXP das nix läuft, ich werde mir mal in den nächsten tagen einen alten recher aus dem keller Kramen und diesen im netzwerk als Server einrichten mit Win98, werde euch dann mal auf dem laufenden halten.

                      gruß Chris :!:
                      http://www.pc-jump.de/Banner.jpg

                      Probleme mit dem Rechner? Komm in"das Computer Forum" und/oder plaudere einfach über neue Hardware.

                      :!: Tippfehler sind beabsichtigt und dienen nur der allgemeinen Belustigung... :lol:

                      Kommentar


                      • #12
                        Hi,
                        Aber sowohl bei PHP als auch Apache steht XP und ME mit da.

                        Habe auch noch ME drauf (Neben 98) - werde mal testen.

                        MfG SPages
                        Lernen Sie jetzt PHP
                        http://www.php-is-easy.de/obook

                        Kommentar

                        homepage-forum.de - Hilfe für Webmaster! Statistiken

                        Einklappen

                        Themen: 56.686   Beiträge: 429.015   Mitglieder: 28.450   Aktive Mitglieder: 109
                        Willkommen an unser neuestes Mitglied, Emmamueller94.

                        Online-Benutzer

                        Einklappen

                        173 Benutzer sind jetzt online. Registrierte Benutzer: 3, Gäste: 170.

                        Mit 3.502 Benutzern waren am 23.01.2020 um 17:20 die meisten Benutzer gleichzeitig online.

                        Die neuesten Themen

                        Einklappen

                        Die neuesten Beiträge

                        Einklappen

                        Lädt...
                        X