Ankündigung

Einklappen
Keine Ankündigung bisher.

Eigenen Linux vServer mit Plesk, aber kann keine eigene Error Seite verwenden

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Eigenen Linux vServer mit Plesk, aber kann keine eigene Error Seite verwenden

    Hallo,

    ich habe einen eigenen Linux vServer und habe auch eine eigene Error 404 Seite doch, wenn ein Error 404 entsteht z.B. https://www.agw-international.com/8 dann kommt das von Plesk. Ich habe es in den Hosting-Einstellungen angekreuzt, dass man eigenen Error-Seite verwenden kann und habe meiner Error-Seite (https://www.agw-international.com/error404/) in die htaccess Datei eingetragen
    Zuletzt geändert von AGW; 08.10.2020, 18:30.
    AGW von AGW International

  • #2
    Hallo,

    finde die Server-Fehlermeldung eh viel schöner.

    Für die Htaccess-Experten im Forum mal den betreffenden Abschnitt aus der .htaccess posten.
    .
    daniel5959
    FindeLinks.de - Kurzinfos mit Linkempfehlung
    Homepage-FAQs.de - bleibt als Archiv online

    Kommentar


    • #3
      Hallo,

      Code:
      ErrorDocument 404 /error404
      in deiner ".htaccess"-Datei im DocumentRoot dürfte klappen (ungetestet, aus einem meiner Projekte kopiert und angepasst).

      Kommentar


      • #4
        Zitat von superminis Beitrag anzeigen
        Hallo,

        Code:
        ErrorDocument 404 /error404
        in deiner ".htaccess"-Datei im DocumentRoot dürfte klappen (ungetestet, aus einem meiner Projekte kopiert und angepasst).
        Genau den Code habe ich drinnen aber funktioniert eben nicht.
        AGW von AGW International

        Kommentar


        • #5
          Hi,
          hast Du denn eine Seite im Hauptverzeichnis erstellt, die "error404" - ohne Extension - benannt ist?

          Gruß
          Ingo
          Ingo Webdesign

          Kommentar


          • #6
            Zwei mögliche Gründe fallen mir hierzu noch ein.

            Der wahrscheinlichere Grund:

            Dein ErrorDocument ist ein Dokument ist offensichtlich eine "sprechende Adresse" (endet nicht mit .php, .html,...). Das heißt, ich nehme an, du hast in deiner .htaccess-Datei Zeilen drin, die in etwa so aussehen (eventuell auch nur einen Teil der nachfolgend genannten Zeilen). Wenn mich meine Erinnerung hier nicht täuscht (ich könnte auch falsch liegen), müssen die Zeilen für die ErrorDocuments (404, 403,...) unter die Zeilen für die sprechenden URLs.

            Code:
            RewriteEngine on
            Options -MultiViews
            RewriteBase /
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteCond %{REQUEST_FILENAME} !-d
            RewriteRule ^([-0-9a-z_A-Z]+)/?$ $1.php [L]
            Du kannst das natürlich ganz einfach testen, indem du dein Errordocument auf error404.html umbenennst und die Anweisung für das ErrorDocument auch anpasst:

            Code:
            ErrorDocument 404 /error404.html
            Der unwahrscheinlichere Grund: ich habe soeben in der PleskDoku nachgelesen, soweit ich das gefunden habe, sind in der .htaccess-Datei gesetzte ErrorDocuments vorranging gegenüber jenen, die du im Plesk Verwaltungsinterface setzen kannst. Ich bin mir hier nicht sehr sicher, bilde mir aber ein, dass ich noch vor Jahren bei Confixx-Zeiten einmal das Verhalten erlebt habe, dass damals (frag mich nicht, ob das so sein sollte), dass die im Confixx-Verwaltungsinterface gesetzten ErrorDocuments Vorrang hatten. Eventuell kannst du probieren, in Plesk die ErrorDocument Konfiguration anzupassen, zu entfernen oder zu deaktivieren, und zu beobachten, inwiefern sich dadurch das Verhalten ändert.

            Kommentar


            • #7
              Zitat von superminis Beitrag anzeigen
              Zwei mögliche Gründe fallen mir hierzu noch ein.

              Der wahrscheinlichere Grund:

              Dein ErrorDocument ist ein Dokument ist offensichtlich eine "sprechende Adresse" (endet nicht mit .php, .html,...). Das heißt, ich nehme an, du hast in deiner .htaccess-Datei Zeilen drin, die in etwa so aussehen (eventuell auch nur einen Teil der nachfolgend genannten Zeilen). Wenn mich meine Erinnerung hier nicht täuscht (ich könnte auch falsch liegen), müssen die Zeilen für die ErrorDocuments (404, 403,...) unter die Zeilen für die sprechenden URLs.

              Code:
              RewriteEngine on
              Options -MultiViews
              RewriteBase /
              RewriteCond %{REQUEST_FILENAME} !-f
              RewriteCond %{REQUEST_FILENAME} !-d
              RewriteRule ^([-0-9a-z_A-Z]+)/?$ $1.php [L]
              Du kannst das natürlich ganz einfach testen, indem du dein Errordocument auf error404.html umbenennst und die Anweisung für das ErrorDocument auch anpasst:

              Code:
              ErrorDocument 404 /error404.html
              Der unwahrscheinlichere Grund: ich habe soeben in der PleskDoku nachgelesen, soweit ich das gefunden habe, sind in der .htaccess-Datei gesetzte ErrorDocuments vorranging gegenüber jenen, die du im Plesk Verwaltungsinterface setzen kannst. Ich bin mir hier nicht sehr sicher, bilde mir aber ein, dass ich noch vor Jahren bei Confixx-Zeiten einmal das Verhalten erlebt habe, dass damals (frag mich nicht, ob das so sein sollte), dass die im Confixx-Verwaltungsinterface gesetzten ErrorDocuments Vorrang hatten. Eventuell kannst du probieren, in Plesk die ErrorDocument Konfiguration anzupassen, zu entfernen oder zu deaktivieren, und zu beobachten, inwiefern sich dadurch das Verhalten ändert.
              Danke für die Antwort. Anscheinend habe ich meine htaccess Datei überschrieben, weil der Code von ErrorDocuments war weg, aber jetzt funktioniert es.
              AGW von AGW International

              Kommentar

              homepage-forum.de - Hilfe für Webmaster! Statistiken

              Einklappen

              Themen: 56.710   Beiträge: 429.176   Mitglieder: 28.471   Aktive Mitglieder: 45
              Willkommen an unser neuestes Mitglied, hypnoseewaldpipperbremen.

              Online-Benutzer

              Einklappen

              180 Benutzer sind jetzt online. Registrierte Benutzer: 3, Gäste: 177.

              Mit 3.502 Benutzern waren am 23.01.2020 um 17:20 die meisten Benutzer gleichzeitig online.

              Die neuesten Themen

              Einklappen

              Die neuesten Beiträge

              Einklappen

              • ST747
                SPAM an andere mailadresse
                hallo, ich hatte da eine glücksspielwebsite kontaktiert über mail und auch eine antwort erhalten.
                vorsorglich habe ich eine zweitrangige mailadresse angegeben.
                jetzt bekomme ich spammails für glücksspiele z.b. aus .fr (Frankreich).
                aber das mail ging nicht an die zweitrangig mailadresse...
                28.09.2020, 18:12
              • ST747
                Antwort auf SPAM an andere mailadresse
                hallo, ich habe vorsorglich mehrere mailadressen verwendet.
                dabei für alles was mit domäne zu tun hat, eine eigene mailadresse verwendet.
                jetzt war die Sache einfach, über filter habe ich nur die bestimmten absender
                zugelassen, wie den provider und domrobot.
                über ausschluss/verwerfen...
                Gestern, 17:20
              • ST747
                Schriftgröße in Kästchen
                Hallo, besonders beim Text in Kästchen funktioniert die Darstellung Text NICHT richtig,wenn der Benutzer über den Bowser die Schriftgröße einstellt. (mit zoom geht das richtig).
                Ich habe mit z.B. das Kästchen mit width: 14% und die Schrift font-size: 90% eingestellt, natürlich mit mehreren...
                14.10.2020, 21:48
              • ST747
                Antwort auf Schriftgröße in Kästchen
                hi,

                ich habe das Thema abgeschlossen.Mit REM habe ich aber nicht mein Ziel erreicht.
                Trotzdem verwende ich jetzt REM, aber nicht für die Kästchen.
                Dabei habe ich den 62,5% Trick erfahren.
                Mit css Body und font-size 62,5% kann man das auf 10px definieren
                und dann...
                Gestern, 17:13
              • AGW
                zu WordPress wechseln
                Hallo,

                ich möchte gerne zu WordPress wechseln, nur jetzt meine Fragen kann ich meine Seiten genauso übernehmen, nur Text, mit Links und Bilder ohne was zu ändern und wie kann ich die Links bei behalten z.B. /samsung/ .
                ...
                19.10.2020, 19:24
              • AGW
                Antwort auf zu WordPress wechseln
                Danke...
                Gestern, 17:10
              • admin
                Antwort auf zu WordPress wechseln
                AGW ich würde das Google Site Kit empfehlen ;-)

                Link: https://wordpress.org/plugins/google-site-kit/

                Gruß Karl
                Gestern, 15:53
              • Premium-Backlinks
                Backlinks für Seo: Monatlicher Premium-Linkaufbau ab 350,- Euro
                Backlinks sind nach wie vor ein unverzichtbarer Faktor, um in Google Spitzenpositionen erreichen und halten zu können. Dabei ist es von äußerster Wichtigkeit jemanden mit dem Aufbau von Backlinks zu betrauen, der genau weiß, welche Backlinks im Einzelfall benötigt werden und welche auf keinen Fall...
                19.10.2020, 03:11
              • daniel5959
                Antwort auf Backlinks für Seo: Monatlicher Premium-Linkaufbau ab 350,- Euro
                Hallo,

                anderswo gibt es weitere Infos - siehe



                Nur wie eine "professionelle Linkaufbau-Agentur" und "langjährige Erfahrung" sowie "professionelle Redakteure" sich mit "Kleinunternehmerin" in Einklang bringen lassen, das...
                Gestern, 14:57
              • silent
                Diashow
                Guten Tag,
                ich möchte in meiner rechten Div ein Informations-Panal hinzufügen, welches man mit Bildern jederzeit updaten kann. Die Bilder sollen per Diashow angezeigt werden. Das funktioniert auch alles reibungslos. Mein Problem ist es, das ich das nicht hinbekomme, dass sich die Bilder automatisch...
                Gestern, 09:13
              Lädt...
              X